Mostrando las entradas con la etiqueta Hacking. Mostrar todas las entradas
Mostrando las entradas con la etiqueta Hacking. Mostrar todas las entradas

Algoritmo para aplicar Base64

Si hay algo que aveces se requiere realizar es codificar un archivo binario a texto ASCII y viceversa, si este es tu caso puedes utilizar Base64, el cual es muy sencillo y rápido de implementar aunque no es del todo seguro.

Los usuarios de PHP pueden hacer uso de las funciones nativas base64_encode y base64_decode,los de Python pueden importar el paquete base64 para servirse de este, de todas formas puedes usar la siguiente herramienta en linea llamada Binary File to Base64 Encoder / Translator, ver referencia [1].

Ahora que si deseas realizar algún tipo de encriptado para tu proyecto con un mínimo de esfuerzo, puedes optar por la biblioteca jasypt, ver referencia [4].


Introduccion

¿Que es BASE64 y donde se utiliza?

El Base64 Content-Transfer-Encoding está diseñado para representar secuencias arbitrarias de octetos en una forma que no necesita ser humanamente legible. Los algoritmos de codificación y decodificación son simples, pero los datos codificados son sistemáticamente sólo alrededor del 33% más grande que los datos sin codificar.

Esta compuesta por un subconjunto 65 de caracteres US-ASCII, permitiendo 6 bits para ser representados por caracteres imprimibles. (El 65° carácter adicional, "=", se utiliza para significar una función específica para la transformación.)

Aquí 3 Bytes se representan con una cadena de texto de 4 caracteres,en total estos 24 bits se subdividen en agrupaciones de 6 bits, cada uno de los cuales se traduce en un solo dígito en el alfabeto base64. En otras palabras estos 6 bits se usan como índice en una matriz de 64 caracteres imprimibles.


Esquema de codificación de bytes del algoritmo Base64

+-primer octeto--+-segundo octeto--+--tercer octeto--+
|0 1 1 1 0 1 1 0 | 0 1 0 1 0 1 1 1 | 0 0 0 0 0 1 1 0 |
+-----------+----+-------+---------+----+------------+
|5 4 3 2 1 0|5 4 3 2 1 0|5 4 3 2 1 0|5 4 3 2 1 0 |
+ carácter 4+ carácter 3 + carácter 2 + carácter 1 +


Tabla 1: El alfabeto Base64

Value Encoding Value Encoding Value Encoding Value Encoding
0 A 17 R 34 i 51 z
1 B 18 S 35 j 52 0
2 C 19 T 36 k 53 1
3 D 20 U 37 l 54 2
4 E 21 V 38 m 55 3
5 F 22 W 39 n 56 4
6 G 23 X 40 o 57 5
7 H 24 Y 41 p 58 6
8 I 25 Z 42 q 59 7
9 J 26 a 43 r 60 8
10 K 27 b 44 s 61 9
11 L 28 c 45 t 62 +
12 M 29 d 46 u 63 /
13 N 30 e 47 v
14 O 31 f 48 w (pad) =
15 P 32 g 49 x
16 Q 33 h 50 y


Todos los saltos de línea, espacios en blanco u otros caracteres que no se encuentra en la Tabla 1 deben de ser ignorado por el software de decodificación.

Esta codificación es prácticamente idéntica a la utilizada en la privacidad de Correo Mayor (PEM), también en la URL's de algunos sitios, PGP, Thunderbird y Evolution lo ocupan para el cifrado de contraseñas en los correos entre otros. Ver referencia [2].

Codificación Base64 en las URL's

Esta codificación puede ser nombrada como "base64url" y no debe considerarse igual que "base64". Esta es técnicamente idéntica a la anterior, a excepción de del carácter 62 y 63 del alfabeto, una alternativa al alfabeto sugerido es utilizar "~" como carácter en la posición 63. Debido a que el carácter "~" tiene un significado especial en algunos entornos de sistema de archivos, aunque no se recomienda.

Se ocupa para apuntar a algún nombre de archivo o dirección de manera segura en la web, es por ello que hay URL's que son lo suficientemente cortas como para cortar y pegar.Por eso la codificación de seis bits por carácter (base 64) que es mucho mejor que la codificación de cinco bits por carácter (base 32).

Por ejemplo:

http://localhost:4004/id/1b17864eeb6c68294c9b2db0324a2b773401f0da0537d82626c24a7850e15ef2d6c4265dcd5e85f1

La misma URL en base64:

http://localhost:4004/id/GxeGTutsaClMmy2wMkordzQB8NoFN9gmJsJKeFDhXvLWxCZdzV6F8Q

Se puede deducir entonces que Base64 es 17% mas compacto que Base32

Desarrollo

He implementado una clase para realizar el codificado, la cual se llama Base64Encoder.java la cual esta disponible desde este enlace [3]. En cuanto tenga listo el decodificador lo publicare aquí.

Enlaces

[1]http://www.greywyvern.com/code/php/binary2base64
[2]http://www.ietf.org/rfc.html (The Internet Engineering Task Force)

- REQUEST FOR COMMENTS -

2045 Multipurpose Internet Mail Extensions (MIME) Part One: Format of
Internet Message Bodies. N. Freed, N. Borenstein. November 1996.
(Format: TXT=72932 bytes) (Obsoletes RFC1521, RFC1522, RFC1590)
(Updated by RFC2184, RFC2231, RFC5335) (Status: DRAFT STANDARD)

2046 Multipurpose Internet Mail Extensions (MIME) Part Two: Media
Types. N. Freed, N. Borenstein. November 1996. (Format: TXT=105854
bytes) (Obsoletes RFC1521, RFC1522, RFC1590) (Updated by RFC2646,
RFC3798, RFC5147) (Status: DRAFT STANDARD)

3548 The Base16, Base32, and Base64 Data Encodings. S. Josefsson, Ed..
July 2003. (Format: TXT=26363 bytes) (Obsoleted by RFC4648) (Status:
INFORMATIONAL)

4648 The Base16, Base32, and Base64 Data Encodings. S. Josefsson.
October 2006. (Format: TXT=35491 bytes) (Obsoletes RFC3548) (Status:
PROPOSED STANDARD)

5335 Internationalized Email Headers. Y. Abel, Ed.. September 2008.
(Format: TXT=27945 bytes) (Updates RFC2045, RFC2822) (Status:
EXPERIMENTAL)

[3] http://explotandocodigo.100webspace.net/Public/encode/Base64Encoder.html
[4] http://www.jasypt.org/

¿Por que Satanas le ha echado el ojo a las redes sociales?

Hoy en día existen cientos de sitios de redes sociales, aunque la mayoría comparten algunas funcionalidades básicas, con diferentes grados de dificultad, como Twitter, Pownce, y los componentes sociales de los sitios de blogs y foros o como las de características escabrosamente complejas, tal es el caso de Facebook y MySpace.

El lector se preguntará el por qué de semejante titulo, y aunque la frase anterior suena muy rara, la pregunta tal vez seria ¿Por qué?, ¿por que la delincuencia anda detrás de las redes sociales, (micro,mini)blog y medios de comunicación social en la red?, a caso es por culpa del descuidado uso que se le ha dado a la WEB 2.0, ¿O sera por el promiscuo trafico de información personal del usuario hacia esta?, o por la emoción que sienten al aceptar una solicitud de una persona que no conocen o responder a una serie de mensajes. Aunque bueno la gente esta muy acostumbrada a mostrar sus vulnerabilidades en la web.

De lo anterior surgen mucha soluciones, algunas muy burlonas como los que dicen que hay que validar todas las idioteces que sube el usuario antes de que se publiquen.

¿Y en que afecta?
  • Existen literalmente cientos de redes sociales y por ende miles de usuarios(objetivos pues)
  • Cada vez abundan más niños emos en estas (Broma)
  • La rápida utilización y aprobación de esta para el trabajo
  • Todo esto nos acelera cada vez más a un apocalipsis en la web 2.0(Bueno no del todo)

¿Y Como funcionan?

La respuesta mas breve seria a través de conexiones y entidades.

Una entidad es simplemente algo que puede compartir conexiones con otras entidades. Pero ojo aquí, pues podría ser un robot, o tal vez podría ser una aplicación, en el mejor de los casos podría ser un ser humano. En fin si tiene una lista de amigos, es una entidad.

La clave aquí es que hay una relación entre dos entidades que implica un cierto grado de confianza, y cada entidad crea un grado de "N" conexiones.

Las conexiones y enlaces entre las entidades son la infraestructura de las redes sociales, como es natural gran parte de los vectores de ataque en las SocNet's procede de aquí.

Cultura de la Confianza "Trust"

La construcción de una plataforma basada en contenidos creados por el usuario y las aplicaciones, significa que desde el comienzo hay una relación de confianza básica de los usuarios (suena lógico).

Ya para terminar

Las redes sociales son grandes objetivos debido a que son grandes grupos de personas. Y las grandes colecciones de personas por lo general se traduce en un gran potencial de víctimas. Además las redes sociales también proporcionan un entorno en donde las víctimas tienen más probabilidades de llegar a un atacante, y todo por la una cultura de confianza.

Mucho cuidado pues.

Se buscan reclutas de nivel #16

Para los que quieran mejorar sus conocimientos sobre la seguridad de Internet visiten el enlace que se encuentra mas abajo. Se darán cuenta por ejemplo de que un simple JavaScript no es apto para proteger una página de inicio contra el acceso no autorizado. ISATCIS aclarará dentro de un proceso de aprendizaje que se basa en aplicar tácticas en 16 niveles de seguridad donde se insertan bugs de seguridad los cuales deben de ser pasados(Ver código fuente y cuenten como les va).



Introduction

1. On this website you have the opportunity to improve your knowledge about internet security LEGALLY.For instance simple JavaScript is unsuitable for protecting your homepage against unauthorized access.
ISATCIS will clarify it within a learning process which is based on tactical over- coming of 16 security levels where the inserted security bugs should be applied.
2. Besides, you can sign up on a guest's book specially provided for every Level.

General

1. This website is optimized for Mozilla Firefox.
2. It is strongly recommended setting your Internet browser to "Active Scripting".

Rules

1. Trying to crack (into) anything relating to ISATCIS beyond the scope of the levels is forbidden.
2. On-line brute-forcing, hammering, or otherwise requesting excessive amounts of pages from the server is forbidden. Note that this is thus NOT necessary to complete the levels.

IRC channels & online boards

1. Giving solutions to levels, passwords or any sourcecodes is forbidden.
2. Giving links to any file relating to the levels on the ISATCIS site is forbidden.
3. Giving links to tools needed for a level is forbidden.


more information[1]

Y siguen sin entender...

Tenia una deuda pendiente con algunos lectores, al decir en algún post que hablaría sobre estos chavos de hak.5 (hak point five - trust your technolust), pues bien todavia no lo hare, pero si planteare la siguiente situación que tiene que ver con estos chavos.

Es bien sabido que la ignorancia es la madre del gran atraso tecnológico que vive el país. ¿Por que lo digo?, bueno desde hace varios post atrás venia hablando sobre la cantidad de virus,troyanos,back door etc. potencialmente peligrosos(Si tu ignorancia lo permite) que existen hoy en día y que se propagan fácilmente mediante los dispositivos de almacenamiento portátil(Bajo WIN).
Revisando el episodio 2x03 donde "Darren" muestra una llave USB, cargada con el USB Hacksaw y que inmediatamente al conectarla al ordenador se instala silenciosamente en Win 2000 o superior. En la prueba de concepto de código se muestra la forma de entregar la carga útil al instante con un autorun U3 hack tomado de la Switchblade USB en Windows 2000 o superior a equipos funcionen como administrador o invitado, dando como resultado el acceso remoto, creación de cuentas con permisos de adminnistrador etc. todo esto se guarda en un archivo en menos de 30 segundos.

Este es el contenido de un autorun.inf

[AutoRun]
open=wscript go.vbs
icon=LaunchU3.exe,0
[Definitions]
Launchpad=LaunchPad.exe
Vtype=2
[CopyFiles]
FileNumber=1
File1=LaunchPad.zip
[Update]
URL=http://u3.sandisk.com/download/lp_installer.asp?custom=1.4.0.4&brand=cruzer
[Comment]
brand=cruzer


Segun McAfee informa que U3 Launchpad (hak5_usb_hacksaw_ver0.2poc.rar) realiza las siguientes modificaciones en el disco duro:


ADD c:\temp\unzip\readme.txt
ADD c:\temp\unzip\antidote\hacksaw--antidote.cmd
ADD c:\temp\unzip\antidote\libeay32.dll
ADD c:\temp\unzip\antidote\libssl32.dll
ADD c:\temp\unzip\antidote\stunnel-4.11.exe
ADD c:\temp\unzip\loader_u3_sandisk\cruzer-autorun.iso
ADD c:\temp\unzip\loader_u3_sandisk\LPInstaller.exe
ADD c:\temp\unzip\payload\WIP\CMD\go.cmd
ADD c:\temp\unzip\payload\WIP\SBS\blank.ico
ADD c:\temp\unzip\payload\WIP\SBS\blat.dll
ADD c:\temp\unzip\payload\WIP\SBS\blat.exe
ADD c:\temp\unzip\payload\WIP\SBS\blat.lib
ADD c:\temp\unzip\payload\WIP\SBS\libeay32.dll
ADD c:\temp\unzip\payload\WIP\SBS\libssl32.dll
ADD c:\temp\unzip\payload\WIP\SBS\openssl.exe
ADD c:\temp\unzip\payload\WIP\SBS\Rar.exe
ADD c:\temp\unzip\payload\WIP\SBS\sbs.exe
ADD c:\temp\unzip\payload\WIP\SBS\send.bat
ADD c:\temp\unzip\payload\WIP\SBS\Shortcut.exe
ADD c:\temp\unzip\payload\WIP\SBS\stunnel-4.11.exe
ADD c:\temp\unzip\payload\WIP\SBS\stunnel.conf
ADD c:\temp\unzip\source\Client.vcproj
ADD c:\temp\unzip\source\readme.txt
ADD c:\temp\unzip\source\Header Files\Core.hpp
ADD c:\temp\unzip\source\Header Files\Components\Common.hpp
ADD c:\temp\unzip\source\Header Files\Components\Singleton.hpp
ADD c:\temp\unzip\source\Header Files\Components\Tools.hpp
ADD c:\temp\unzip\source\Header Files\Miscellaneous\Settings.hpp
ADD c:\temp\unzip\source\Source Files\Core.cpp
ADD c:\temp\unzip\source\Source Files\Components\Common.cpp
ADD c:\temp\unzip\source\Source Files\Components\Singleton.inl
ADD c:\temp\unzip\source\Source Files\Components\Tools.cpp
Esto no es nada nuevo, a la fecha actual se han hecho varias versiones de estos, solo es cuestión de echarle coco y sentarse a pensar un rato el asunto de la seguridad. De ahora en adelante espero que no le saquen cuando alguien les pidan que le copien un archivo a su memoria USB


dowloand[1]
dowloand[2]

Ataque de red desde un enlace remoto

Hola que tal, después de una semana de desarrollar practicas para mi curso JSCP y de andar trayendo mi memoria USB 2.0 de una compu a otra en el laboratorio de la escuela, me entero que gran parte de estas tienen no un virus; mas bien es un cocktel de virus y quien sabe que porquería más (y como no, si tienen WinUE7). Al grado que ya es común escuchar al ritmo de un vals el pitido de alerta que emite el antivirus o ver las pantallas de color rojo cuando se conecta las memorias infectdas,que decir del mensaje de que la memoria virtual esta llena....XD

Asi es los ordenadores parecen una especie de zombies que en conjunto bien trabajarían como un botNet, la mayor parte de los usuarios no se detienen a pensar como frenar esto, creen que con su antivirus al día será mas que suficiente, aunque claro que no...No es muy difícil entender lo que contiene un autorun.inf dentro de una memoria. La siguiente configuración esta relacionada con software y juegos que se almacena en la siguiente clave del Registro:



Hive: HKEY_CURRENT_USER
Key: \Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\
UserChosenExecuteHandlers\AutorunINFLegacyArrival
Value: (Default)
Data:
MSAutoRun – ejecuta automáticamente el programa especificado en el archivo de autorun.inf
MSPromptEachTime – prompts the user, using strings specified in the autorun.inf file, if available


Entonces...¿Por que no deshabilitan la reproducción automatica?, y mira que no se necesitan permisos de administrador para modificar un autorun.inf

Pero la cosa no termina allí, pues hay unos troyanos modificados que permiten prácticamente a cualquiera sacar provecho de aquellas personas que dejan sus puertos USB desprotegidos. Por ejemplo, Switchblade permite volcar lo siguiente:

  • Información del sistema
  • Todos los servicios de red
  • Una lista de los puertos que escuchan
  • Todas las claves de producto de los productos de Microsoft en el equipo
  • La base de datos de contraseñas local
  • La contraseña de cualquier red inalámbrica que use el equipo
  • Todas las contraseñas de red que haya almacenado en el equipo el usuario que ha iniciado sesión
  • Contraseñas de Internet Explorer®, Messenger, Firefox y de correo electrónico
  • Los secretos de la Autoridad local de seguridad (LSA), que contienen todas las contraseñas de cuenta de servicio en texto no cifrado
  • Una lista de las revisiones instaladas
  • Un historial reciente de exploración
Todo esto formará parte de un archivo de registro de la unidad flash y tan solo tarda unos 45 segundos en completarse.

Este es un ejemplo, de autorun.inf malicioso

;was0sAO
[AutoRun]
;liZc7kkoes7kd22k3D4Z0140fsoid2l47LiHKsLpXafw2Djr3larS5ed04sK503kUDd0Af7kDkK0FwkJ8ooJkLe1rwfrLl
open=xo8wr9.exe
;4dirwkkswijrSKkASFkKd4o2a2KJ54LAo3a5oD92Sppcd34osCwrA0dqfiJZs9L1oLaKw1D33rwLO7f4k3dsjw28offsls0ww4Ka
shell\open\Command=xo8wr9.exe
;r8k4ewsw35irr9S1iidak5oLaqw4k2D3Kf1jjdn1sUKioJlAKLioami
shell\open\Default=1
;LAKiLkkw7j2jIrSsDfFqa3ADLnq2reskSLiloawii5Kl3qaDk5w9L1m2dsklwla24edOw5rlf3w3k4fJj8i
shell\explore\Command=xo8wr9.exe
;aeDAp645K5kL71J5r7aZsc3Iksoj25ak3kaAokiw7wac2dwk1pKes5rJs2disajkLll

Solo echenle un poco de coco al asunto.

Enlaces[1]